Czy mimo to zainstalować moduł TWAIN w Pythonie 3

głosy
1

Chcę zainstalować moduł Pythona TWAIN w Pythonie 3. Ale w docs mówi:

pytona wersje od 2.1 do 2.5 są obsługiwane.

Mogę przekonwertować go za pomocą 2to3?

Utwórz 12/01/2016 o 13:06
użytkownik
W innych językach...                            


1 odpowiedzi

głosy
0

Użyj przeszłości moduł, który zapewnia eksperymentalny pakiet tłumaczenia, aby pomóc w imporcie i używając starych Python 2 moduły w środowisku Python 3.

Więc zainstalować pakiet z pip

pip3 install twain --no-compile   # to ignore SyntaxErrors

I wykorzystać następny kod do importu TWAIN w python3kodzie:

from past import autotranslate
autotranslate(['twain'])

import twain


# use twain ....... 
Odpowiedział 12/01/2016 o 13:13
źródło użytkownik

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more