Po przeniesieniu serwera i IP, stylów i innych zasobów nie znaleziono (404 błędy w Skrzypek)

głosy
28

I zostały przeniesione sadzie witryny CMS z jednego hosta i serwera do innego hosta i serwera. Adres IP jest oczywiście inna.

Wszystkie pliki zostały poprawnie skopiowane i prawidłowe HTML jest renderowane.

Jednak wszystkie arkusze stylów produkować błąd 404. Powtarzam, że pliki są tam, gdzie być powinny.

Rzeczywiście, każdy inny zasób, takich jak obrazy czy stylów produkować ten sam problem. Ponownie, pliki są na swoim miejscu.

Czy ktoś może pomyśleć, co może być przyczyną tego. Nic się nie zmieniło inne niż serwer i IP.

Mam inną stronę sadu na tym samym IP oraz serwera, na którym działa poprawnie. Jednak nie został przeniesiony z innego serwera.

I ping na miejscu i pochodzi z prawidłowym adresem IP dla nowego serwera

EDYTOWAĆ:

Nie jestem pewien, że jest to specyficzny Orchard, chociaż coś związane z tematami sadu i jak one działają mógłby być winien ... Ale ja naprawdę nie widzę co.

To brzmi bardziej jak problem IIS.

Utwórz 15/05/2013 o 10:16
użytkownik
W innych językach...                            


2 odpowiedzi

głosy
0

Można pobrać pliki CSS, wpisując ich adresy URL w przeglądarce adresu bar bezpośrednio?

Spróbuj „Kopiuj lokalizację obrazu” albo z właściwości obrazu, jednej z nieudanych zdjęć. Ponownie, można uzyskać to, jeśli wchodzi ona kierować w przeglądarce?

Sprawdź URL nieudanych środków przeciwko URL zasobów HTML roboczych lub dynamicznych stron. upewnij się, że nie ma żadnych różnic w ścieżce webapp lub kontekstu ..

Trzeba także spróbować Ctrl-R przeładowaniem.

Nie może też być ewentualnie niektóre buforowanie w drodze .. że może być przytrzymanie „404” lub „nie znaleziono” rezultaty, nawet po zawartość została przeniesiona. Try & shutdown / lub siła odświeżyć wszystkie bufory serwera & proxy.

Odpowiedział 15/05/2013 o 10:25
źródło użytkownik

głosy
0

Ludzie serwerów wrócił do mnie. zmieniły one „strona do 4,0 Zintegrowanego Pipeline tryb.” i wszystko teraz działa. Domyśl.

Jestem pewien, że sprawdził, że był w trybie zintegrowanym rurociąg, ale hej ho.

Odpowiedział 15/05/2013 o 11:34
źródło użytkownik

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more